Bitbucket Cloud website outage
Incident Report for Atlassian Bitbucket
Postmortem

SUMMARY

On March 13th at 6:10 pm UTC all primary Bitbucket services became unreachable due to internal authentication issue with a primary database. This was a result of the database configuration error which was promptly reverted leading to an immediate recovery across all services at 6:28 pm UTC.

IMPACT

On March 13th between 6:10 pm UTC and 6:28 pm UTC https://bitbucket.org was unreachable. This included web traffic, API traffic, and Pipeline builds. This did not impact Git, HTTPS or SSH, traffic.

ROOT CAUSE

The issue was identified as an configuration error with the primary application database.

REMEDIAL ACTIONS PLAN & NEXT STEPS

We know that outages impact your productivity. While we have a number of testing and preventative processes in place, this specific issue happened through manual database configuration being done to remediate a separate prior incident.

We will be putting in place preventative improvement actions which will include adding automation to prevent a similar issues from happening in the future.

We apologize to customers whose services were impacted during this incident; we are taking immediate steps to improve the platform’s performance and availability.

Thanks,

Atlassian Customer Support

Posted Mar 16, 2023 - 22:39 UTC

Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 18:47 UTC
Monitoring
We have fixed the issue affecting Bitbucket Cloud. We are currently monitoring the results.
Posted Mar 13, 2023 - 18:35 UTC
Investigating
We're currently investigating an outage in Bitbucket Cloud and other products. We will provide more information as we work to identify the root cause.
Posted Mar 13, 2023 - 18:26 UTC
This incident affected: Website, API, Git via SSH, Authentication and user management, Git via HTTPS, Webhooks, Source downloads, Pipelines, and Git LFS.