Bitbucket.org is down
Incident Report for Atlassian Bitbucket
Postmortem

SUMMARY

On July 25, 2023, between 16:29 UTC and 16:44 UTC, Atlassian customers were unable to access the Bitbucket Cloud website. This was caused by a code bug that made it to our production environment. The incident was detected immediately by our internal monitoring and fully resolved within 15 minutes by reverting the change.

IMPACT

Customers who were impacted were unable to access the Bitbucket | Git solution for teams using Jira website during the duration of the incident. APIs, Bitbucket Pipelines, and Git over HTTPS and SSH were fully functional.

ROOT CAUSE

The incident was caused by a bug that made it into our production environment. This bug affected our ability to communicate with our caches and prevented some of our internal services from starting up to serve traffic to our website. This bug has been fixed and deployed to production.

REMEDIAL ACTIONS PLAN & NEXT STEPS

We know that outages impact your productivity. We are prioritizing the following improvement actions to avoid repeating these types of incidents in the future and reduce recovery time:

  • Improve testing in non-production environments
  • Enhance monitoring around service deployments

We apologize to customers whose services were impacted during this incident; we are taking immediate steps to improve the platform’s availability.

Thanks,

Atlassian Customer Support

Posted Jul 28, 2023 - 18:50 UTC

Resolved
This incident has been resolved.
Posted Jul 25, 2023 - 17:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2023 - 16:49 UTC
Investigating
We are seeing issues related to bitbucket website and we are currently investigating the root cause.
Posted Jul 25, 2023 - 16:47 UTC
This incident affected: Website.