Git pushes and merges are degraded
Incident Report for Atlassian Bitbucket
Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 14:09 UTC
Monitoring
After making a configuration change to our service responsible for handling Git hooks, we are seeing response times return to normal across all operations. We'll continue to monitor our systems and resolve this incident after performance has remained stable for 30 minutes.
Posted Jun 11, 2021 - 11:59 UTC
Update
We have successfully resolved the bottleneck in our database layer and have seen response times return to normal across most operations. However, we are continuing to see issues affecting pushes and merges. We are now directing our efforts towards identifying the cause of these last remaining issues and addressing it.
Posted Jun 11, 2021 - 11:50 UTC
Identified
We have identified the issue as a bottleneck in our database layer, which is impacting multiple systems including the website and API in addition to our GIt services. We are investigating possible mitigations now.
Posted Jun 11, 2021 - 11:40 UTC
Investigating
We have received alerts that Git push and merge operations are currently degraded. We are investigating and will provide additional updates shortly.
Posted Jun 11, 2021 - 11:28 UTC
This incident affected: Website, API, Git via SSH, and Git via HTTPS.