Pipelines failing to start or hanging due to comms failures
Incident Report for Atlassian Bitbucket
Resolved
Pipelines are now all operating normally.
Posted Apr 28, 2020 - 04:09 UTC
Update
There was an issue with our underlying messaging system where notifications were not being received correctly, between midnight and 12:30 UTC. Pipelines were failing to start in this time and steps that completed in this window will be marked as complete but the pipeline will not complete or move on to the next step. These will timeout within the next hour and be marked as failed (and will not be billed). You can then choose to rerun the failed steps and proceed.
Alternately, you can manually rerun the pipeline by navigating to the commit or branch.

Piplines outside this window are now running fine and you can manually run pipelines against commits pushed in that window.

We are continuing to monitor the situation.
Posted Apr 28, 2020 - 02:23 UTC
Monitoring
We believe we've identified the cause of the incident. The system seems to be recovering and we are monitoring the situation.
Posted Apr 28, 2020 - 01:29 UTC
Update
We are continuing to investigate this issue.
Posted Apr 28, 2020 - 01:25 UTC
Investigating
We're investigating issues with pipelines failing to be triggered or being stuck.
Posted Apr 28, 2020 - 01:13 UTC
This incident affected: Pipelines.