Slow or failing git/hg operations

Incident Report for Atlassian Bitbucket

Resolved

This incident has been resolved.
Posted 5 years ago. Nov 20, 2019 - 13:57 UTC

Monitoring

Emergency network maintenance has completed, and connections are beginning to recover. We're still keeping an eye on backlogs and throughput, though, and will keep this incident open for a little while longer.
Posted 5 years ago. Nov 20, 2019 - 13:22 UTC

Update

We are continuing to investigate this issue.
Posted 5 years ago. Nov 20, 2019 - 12:45 UTC

Update

Adding webhooks to this.
Posted 5 years ago. Nov 20, 2019 - 12:28 UTC

Investigating

We've received alerts about failing Git and Mercurial operations, including pushes, pulls, and clones, and extending to Pipelines-related tasks. This appears to be related to some emergency upstream network maintenance but our engineers are currently investigating.
Posted 5 years ago. Nov 20, 2019 - 12:15 UTC
This incident affected: Website, API, Git via SSH, Git via HTTPS, Webhooks, Source downloads, and Pipelines.