Issues during merge in the PR
Incident Report for Atlassian Bitbucket
Resolved
This incident has been resolved.
Posted Dec 03, 2019 - 14:34 UTC
Monitoring
We have identified the root cause for the issues during the merge and have mitigated the problem. We are now monitoring closely.
Posted Dec 03, 2019 - 13:46 UTC
Update
The previous update, didn't contain all the steps for the workaround:

Switch to old Pull Request view:
Click on your Avatar on the left bottom. Select 'Bitbucket Labs'
Disable 'New pull request experience beta'
Go to your repository Settings - Merge Strategies. And choose 'Merge Commit'
Go to the opened PR page. Click 'Merge' and change the strategy back to the 'Squash' merge. And, merge the PR
Posted Dec 03, 2019 - 13:21 UTC
Update
Our team is still working on the final fix. As a workaround we would like to recommend to switch back to the Old pull requests experience, by going to your account's settings - Labs and enabling the Old pull requests feature.
Posted Dec 03, 2019 - 12:49 UTC
Investigating
We are investigating cases of degraded performance for merging Pull Requests using Squash strategy for Atlassian Bitbucket Cloud customers. We are going to more details about this incident in the next hour.
Posted Dec 03, 2019 - 12:10 UTC
This incident affected: Website.